Jump to content


  • Please log in to reply
(June 21th 2019 / windows 10) - endless loading when trying to open world map
3 replies to this topic - Started By skvo, Jun 21 2019 08:44 AM

#1 skvo

skvo
  • Members
  • 2 posts
  • Pip

Posted 21 June 2019 - 08:44 AM

the game worked well until the last update InDev 33f. the game starts, the main menu opens, but world map have endless loading, so I must close game using task manager

 

java version 8.0.211

 

Intel® Core™ i7-6700 CPU @ 3.40GHz 3.41GHz

 

AMD Radeon ™ R9 360

 

RAM 8 gb

 

Rise to Ruins InDev 33f
 
Attempting to initialize Steamworks
 
Fetching local language files.
Attempting to load: C:\Program Files (x86)\Steam\steamapps\common\Rise to Ruins\localization\defaultEnglish
 
Fetching Steam Workshop language files, if logged in to Steam.
Attempting to load: C:\Program Files (x86)\Steam\steamapps\workshop\content\328080\1633031151
 
Total word count: 23146
Total key count: 5153
Text key count: 4009
 
Loading Font Data
Starting Dedicated Threads
Thread Pool Size: 8
 
Operating System: Windows 10
GPU Drivers: aticfx64
GPU Driver Version: 8.17.10.1653
Maximum JVM Memory: 1808MB
Fri Jun 21 16:38:10 MSK 2019 INFO:Slick Build #237
Initializing Display Mode: Windowed
Fri Jun 21 16:38:10 MSK 2019 INFO:LWJGL Version: 2.9.3
Fri Jun 21 16:38:10 MSK 2019 INFO:OriginalDisplayMode: 1920 x 1080 x 32 @59Hz
Fri Jun 21 16:38:10 MSK 2019 INFO:TargetDisplayMode: 1820 x 880 x 0 @0Hz
Fri Jun 21 16:38:12 MSK 2019 INFO:Starting display 1820x880
Fri Jun 21 16:38:12 MSK 2019 INFO:Use Java PNG Loader = true
Fri Jun 21 16:38:13 MSK 2019 INFO:Controllers not available
Resetting MAIN_MENU
Loading Game
font Module: 5637
save Module: 0
time Module: 0
Fri Jun 21 16:38:19 MSK 2019 INFO:Initialising sounds..
Fri Jun 21 16:38:20 MSK 2019 INFO:- Sound works
Fri Jun 21 16:38:20 MSK 2019 INFO:- 64 OpenAL source available
Fri Jun 21 16:38:20 MSK 2019 INFO:- Sounds source generated
sound Module: 790
Loaded Tileset: SAND_RED (3015000) Time: 43
Loaded Tileset: SANDSTONE_RED (415000) Time: 684
Loaded Tileset: WATER (3610000) Time: 107
Loaded Tileset: WATER_ACCENT (3610500) Time: 84
Loaded Tileset: SAND_RED_ACCENT (3015500) Time: 62
Loaded Tileset: LAVA (2810000) Time: 175
Loaded Tileset: SANDSTONE_RED_ACCENT (415500) Time: 153
Loaded Tileset: FLOWERS_PURPLE (2220000) Time: 38
Loaded Tileset: LAVA_ACCENT (2810500) Time: 180
Loaded Tileset: CRYSTAL_PURPLE (625000) Time: 324
Loaded Tileset: TREES_BROWN_DEAD (15500) Time: 198
Loaded Tileset: TREES_BROWN (15000) Time: 126
Loaded Tileset: CACTUS_GREEN (1210000) Time: 156
Loaded Tileset: CACTUS_GREEN_ACCENT (1210500) Time: 17
Loaded Tileset: MIGRATION_WAY_STATION (211405500) Time: 419
Loaded Tileset: HOUSING (206205500) Time: 376
Loaded Tileset: COBBLE_AND_BOARD_ROAD (4013000) Time: 271
Loaded Tileset: TREES_BROWN_ACCENT (16000) Time: 156
Loaded Tileset: FLOWERS_BLACK (2210000) Time: 95
Loaded Tileset: FLOWERS_BLUE (2215000) Time: 124
Loaded Tileset: MELONS (1610000) Time: 215
Loaded Tileset: FLOWERS_BLUE_ACCENT (2215500) Time: 51
Loaded Tileset: ANCIENT_RADIANCE_POOL (200600500) Time: 236
Loaded Tileset: BOTTLER (202005500) Time: 584
Loaded Tileset: TILES (3410000) Time: 210
Loaded Tileset: CUT_STONE_AND_BOARD_ROAD (4014000) Time: 147
Loaded Tileset: LARGE_FOUNTAIN (206605500) Time: 191
Loaded Tileset: ANCIENT_CULLIS_GATE (200400000) Time: 180
Loaded Tileset: WATER_PURIFIER (214405500) Time: 361
Loaded Tileset: CRYSTAL_PURPLE_ACCENT (625500) Time: 130
Loaded Tileset: CRYSTILLERY (203805500) Time: 416
Loaded Tileset: COBBLE_AND_LOG_PATH_DEBRIS (4011500) Time: 49
Loaded Tileset: CRYSTAL_STORAGE (203605500) Time: 299
Loaded Tileset: WOOD_GOLEM_COMBOBULATOR (215005500) Time: 293
Loaded Tileset: SMALL_FOUNTAIN (212405500) Time: 235
Loaded Tileset: KITCHEN (210005500) Time: 181
Loaded Tileset: WOOD_FENCE (4214000) Time: 224
Loaded Tileset: MELONS_ACCENT (1610500) Time: 15
map Module: 8192
road Module: 22
miniMap Module: 366
resource Module: 79
transition Module: 0
shadow Module: 1177
lighting Module: 156
projectile Module: 0
missile Module: 21
particle Module: 127
collision Module: 37
depth Module: 39
perk Module: 6
god Module: 0
goal Module: 0
object Module: 1545
background Module: 21
mob Module: 1980
mobJob Module: 0
essence Module: 0
weather Module: 1
corruption Module: 3
profile Module: 0
Map FBO: 468
map Module Sync: 0
road Module Sync: 2
resource Module Sync: 1
missile Module Sync: 34
object Module Sync: 2
mob Module Sync: 14
essence Module Sync: 0
TOTAL TIME: 26242
Loaded Tileset: TREES_BROWN_COLLECTED (16500) Time: 160
SKELETON NONE AI AI_WANDER STEP 1 time to execute was high: 197
SLIME NONE AI AI_WANDER STEP 1 time to execute was high: 61
HEADLESS NONE AI AI_START STEP 0 time to execute was high: 53
Loaded Tileset: SANDSTONE_RED_COLLECTED (416000) Time: 67
SKELETON NONE AI AI_WANDER STEP 1 time to execute was high: 91
 

 


  • 0

#2 skvo

skvo
  • Members
  • 2 posts
  • Pip

Posted 03 September 2019 - 11:35 AM

oh, thank you. i am waiting for 2 months+. you dont care. i spend my money and receive zero help. amazing. i hope no one else gets into my situation. bye


  • 0

#3 Psycho0124

Psycho0124
  • Members
  • 5 posts
  • Pip

Posted 03 September 2019 - 09:15 PM

I had a similar issue and solved it by deleting some of the autosave files and reverting to a working version of the world. I'll walk you through it.

 

Right-click the game in steam and go to 'Properties'. Click the 'Updates' tab and uncheck 'Steam Cloud Synchronization' so steam doesn't go restoring the files we're going to be removing.

Now tab over to 'Local Files'. Click 'Browse Local Files'.

You'll see some folders.

First, make a copy of the 'Profiles' folder and stash it somewhere else for safe keeping (I use a Temp folder on my desktop).

Now open 'Profiles, then 'Profile0', 'Saves', 'WorldMap', then 'WorldMaps'.

 

In here, you'll see some region names corresponding to your villages. The last village you played on is probably the culprit so start there. Open up the folder and you'll see the autosave files. Move all but the lowest number out and start the game. If you can access your world map and load villages, you can either continue from here or try adding back later autosaves one at a time and re-launching the game to get more of your progress back.

 

If your worldmap still doesn't load, move out the whole village folder and try opening the world map again. You'll have to start over in that region but at least the world will be accessible. If removing the village folder doesn't fix it, try other folders corresponding to other villages in there, prioritizing ones you played most recently.

 

If you're still hanging on world map, go back to the 'WorldMap' folder and go into 'WorldSaveData'. Start removing the highest number save and loading the world map.

 

If none of these steps get the worldmap working again, you might need to just start a new profile by deleting the 'profile0' folder entirely. Not sure if the devs are interested in troubleshooting individual problems like this unfortunately..


  • 0

#4 Tiberiumkyle

Tiberiumkyle
  • Moderators
  • 84 posts
  • Pip

Posted 03 September 2019 - 10:16 PM

oh, thank you. i am waiting for 2 months+. you dont care. i spend my money and receive zero help. amazing. i hope no one else gets into my situation. bye

 

Apologies for the lack of response, you seem to have sadly fallen through the cracks. This forum doesn't see much activity thus isn't checked as often. For future issues I strongly recommend using the Steam forums https://steamcommuni...80/discussions/

 

 

Did you have many regions in that save? If so and you still have it, it may be worth trying the unstable branch, which has additional optimizations to help with save/load times, but the initial load may still take awhile, just have to wait for it to finish.


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users