Jump to content


  • Please log in to reply
[InDev 31 / Windows 10] Labor Golem stuck to my hand
No replies to this topic - Started By Xtavatic, Sep 22 2018 11:34 AM

#1 Xtavatic

Xtavatic
  • Members
  • 2 posts
  • Pip

Posted 22 September 2018 - 11:34 AM

I managed to somehow get a labor golem stuck to my hand. I tried to abuse ancient cullis gates for essence and ran into this bug while pulling it off.

 

So this is what i did:

 

1. Setting up

Set up an ancient cullis gate such that the north side is facing a large body of water, while having at least 3 lightning rods adjacent to the gate.

 

2. Position Mouse

I hovered the cursor over the bottom edge of the water, just slightly above the gate, such that you can pick up water and drop it into the gate without moving the cursor.

 

3. Mash Buttons

Since the hot key [ ` ] that select the grab spell also releases the item that you're holding, you can rapidly mash both the mouse button and the grab hotkey [ ` ] at the same spot to drop water into the gate at a phenomenal rate. The essence generated by the gate will be enough to fuel your grab casts indefinitely, while the area quickly swarms with essence. I managed to remove water from the sea so rapidly that sometimes the entire sea can be pulled dry for a brief moment.

 

Everything went pretty well in my game until I decided to raise an army of labor golems with my essence. One of them walked to where my cursor was when I was putting in the work. I ended up grabbing the golem, and was unable to release the golem. When I grab something else, the other item gets grabbed with the golem still in my hand, and when I release it, the item get released, but not the golem. I tried exiting to the map then enter the region again, only to see the golem stlll stuck to my hand. Restarting the game did not work either. Everything works fine with the golem stuck to my hand, except for being unable to select buildings when I click on them, I just end up selecting the golem on my hand instead.

 

Edit: Oops it seems that there is another thread about this bug, resetting the AI fixed the problem


  • 0





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users