Jump to content

bug

  • Please log in to reply
[InDev 28b | Win 7]
7 replies to this topic - Started By BlanKitt, Oct 16 2017 08:11 PM

#1 BlanKitt

BlanKitt
  • Members
  • 6 posts
  • Pip

Posted 16 October 2017 - 08:11 PM

Bug Description - Game crashes to crash log when I attempt to use 3x speed and upgrade some roads. I have a fairly decent size village, set of resources etc so probably that's the fault of using the finicky 3x speed.

 

OS - Win 7

 

Crash log

 

---

Seems now it's crashing just loading into my village/world. :( Dunno if the log is any different, but it's here.


  • 0

#2 Rayvolution

Rayvolution
  • Developer
  • 1,890 posts
  • Pip
  • Steam ID:Rayvolution
  • LocationTexas

Posted 17 October 2017 - 02:21 PM

This isn't actually related to your speed controls, one of your farms are bugged. There's a known issue I dug up yesterday I'm working to fix for InDev 28c. 

 

I can fix your save if you'd like, or you can try to fix it yourself by finding the bugged farm and dismantling it.

 

If you want me to fix it, go to the profile select screen, click the arrow button, then "dev request" and upload. That'll send me your profile. I can repair it and return it to you. :)

 

If your profile name is different than your username here, let me know what it is so I can dig it up.


  • 0
Rise to Ruins Developer

#3 BlanKitt

BlanKitt
  • Members
  • 6 posts
  • Pip

Posted 17 October 2017 - 05:18 PM

Interesting, I wonder what causes the bug? I imagine that the bug doesn't get triggered when the original cause doesn't load it, and that's why I was able to make a second land/village area without any issues..

 

Nevertheless, I'll have to send it to you, as I can't make it into the village/land in the profile without it crashing :(

 

Profile name is Kitt 28b

 

Thank you very much for your help and speedy reply though! :)


  • 0

#4 Rayvolution

Rayvolution
  • Developer
  • 1,890 posts
  • Pip
  • Steam ID:Rayvolution
  • LocationTexas

Posted 18 October 2017 - 02:07 PM

All fixed. I had to dismantle the offending farm (the top most one in your village). :)

 

http://risetoruins.c...nk/BlanKitt.zip

 

Just drop the profile0 folder in /profiles/ in the game's install folder. You can rename it to profile1, 2, 3 or 4 to change the slot it's in.

 

I'll try to get the actual original bug fixed next patch.


  • 0
Rise to Ruins Developer

#5 BlanKitt

BlanKitt
  • Members
  • 6 posts
  • Pip

Posted 18 October 2017 - 08:19 PM

Thank you very much. :) I'll post a review on Steam actually as further thanks.  :D


  • 0

#6 Rayvolution

Rayvolution
  • Developer
  • 1,890 posts
  • Pip
  • Steam ID:Rayvolution
  • LocationTexas

Posted 19 October 2017 - 09:05 AM

Thank you very much. :) I'll post a review on Steam actually as further thanks.  :D


Awesome! Thanks. Every review counts! :)
  • 1
Rise to Ruins Developer

#7 Rayvolution

Rayvolution
  • Developer
  • 1,890 posts
  • Pip
  • Steam ID:Rayvolution
  • LocationTexas

Posted 21 October 2017 - 02:02 PM

The bug has been fixed next patch (InDev 28c) so you shouldn't see it creep up again once it's released next week. :)


  • 0
Rise to Ruins Developer

#8 BlanKitt

BlanKitt
  • Members
  • 6 posts
  • Pip

Posted 21 October 2017 - 06:30 PM

The bug has been fixed next patch (InDev 28c) so you shouldn't see it creep up again once it's released next week. :)

 

Gracias Ray :)


  • 0





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users