Jump to content


  • Please log in to reply
IDK if this is a game bug or a system thing
1 reply to this topic - Started By Egiap, Sep 04 2017 03:43 PM

#1 Egiap

Egiap
  • Members
  • 1 posts
  • Pip

Posted 04 September 2017 - 03:43 PM

When I Googles the error it led me to a wiki  forum for another game, so I am to believe that this is a system falure and not the fault of the game dev. But IP want to be sure.

 

 

Mon Sep 04 17:34:03 EDT 2017 ERROR:org.lwjgl.openal.AL10.nalSourcef(IIF)V
java.lang.UnsatisfiedLinkError: org.lwjgl.openal.AL10.nalSourcef(IIF)V
    at org.lwjgl.openal.AL10.nalSourcef(Native Method)
    at org.lwjgl.openal.AL10.alSourcef(AL10.java:810)
    at org.newdawn.slick.Sound.setGain(Sound.java:179)
    at rtr.SoundModule.runEnviromentalAudio(SoundModule.java:388)
    at rtr.SoundModule.update(SoundModule.java:372)
    at rtr.states.MainMenuState.update(MainMenuState.java:192)
    at org.newdawn.slick.state.StateBasedGame.update

 

 

 

I don't know how much of the message would be helpful in identifying the issue, so if more is needed please ask.

will give cookie to anyone that helps.  🍪


  • 0

#2 Rayvolution

Rayvolution
  • Developer
  • 1,924 posts
  • Pip
  • Steam ID:Rayvolution
  • LocationTexas

Posted 07 September 2017 - 06:00 PM

According to the crash you have no sound devices on your PC at all! :)

 

Does your laptop not have a built in sound device, or have you disabled it? If you re-enable it, the game should kick back on.

 

Some laptops (although it's extremely rare) that don't have built in speakers sometimes disable the sound device if you unplug the headphones from the headphones jack, if that's the case, try plugging some in and see what happens.


  • 0
Rise to Ruins Developer





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users